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Dear customer, 

every year thousands of customers purchase our high quality products.  
With very good reason: 

 Our products offer a very good price/performance ratio. Reliable quality at a fair price. 

 With a professional experience of over 20 years, we are able to find the optimal solution for 

your measuring task. 

 Our high quality standards. 

 Of course, all of our equipment bears the CE mark required by the EU. 

 Calibration certificates, seminars and consulting. 

 After the purchase we will not leave you standing in the rain. 

Our service ensures rapid assistance for you. 
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1 Introduction 

With the help of OMClient, the stored measurement values can be visualized and evaluated. 

2 First Start 

 The first time the application is started a notice will be displayed, stating that a connection to 
the database cannot be established. 

 

Illustration 1: No database connection 

 By pressing the "Retry" button the "database configuration" dialogue is automatically opened. 

 The dialogue “database configuration“ is filled with the standard parameters for the MySQL 
database. 

 Now you can change the parameters for the MySQL database: 

 

Illustration 2: Database configuration 

 

 
 
 
 
 
 

 Name/IP address of the computer 
where the MySQL database is installed. 

 

 Port of the MySQL database (default: 
3306 - see Install Guide p. 11) 

 

 Name of the database (default: 
cs_omdatabase - see Install Guide p. 
13) 

 

 Database User: root 

 

 Password for the database access (see 
the Install Guide, p. 13 (default: 
CS_DB) 
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 The dialog for the configuration of the MySQL database connection can be called up at any 
time via the menu item "Extras -> Database configuration". 

 After correctly entering the database configuration the logon dialog will appear. Enter the 
correct login credentials. The credentials were established with the help of OMServerGUI (see 
Manual METPOINT connect OMServerGUI p. 14) 

 Subsequently a message will appear stating that a connection to the OMServer can not be 
established: 

 

Illustration 3: Connection to Server Lost 

 Acknowledge the warning by clicking "OK". 

 After this the dialogue „“Client Server Communication“ appears. 
The dialogue is filled with the standard parameters fort he Client – Server – Communication. 

 Now you can change the parameters for the Client – Server – Communication: 

 

Illustration 4: Client Server Communication 

 Subsequently restart OMClient. 
 

3 General 

Here, the menu items are described that have the same functionality in all views. 

3.1 Menu File 

3.1.1 Exit 

Exit the OMClient. 

3.2 Menu View 

 This menu can be used to switch through the different views. 

 Name/IP address of the computer 
where the OMServer is installed. 

 

 Port of the OMServer (default: 47825 - 
see Manual Beko Soft Online 
Monitoring ServerGUI p. 13) 
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3.3 Menu Extras 

3.3.1 Alarm texts 

 With this menu item the mask to define the alarm texts is displayed. 

 The alarm texts can also be defined with the OMServerGUI. 

 To be able to define alarm texts the user must at least have a level 3 access authorization. 

 The AlarmId (alarmTextID) is assigned by the software. 

 The alarm texts can also be defined in different languages.  

 A further language can be added with the button "add language". 

 

Illustration 5: Configuring alarm texts 

 

 

 

 

 

 Add alarm text in the selected language 
(highlighted column). 

 
 Edit alarm text in the selected language 

(highlighted column). 

 

 Delete selected alarm texts in all 
languages. 

 

 Edit alarm text. 

 
 Add additional language. 

 
 Accept change. 

 
 Reset change. 

 

 Authorization - changes can be made by others. 

 

 Alarm text editing - the current mask is locked for other users. 
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3.3.2 E-mail recipient configuration 

 The e-mail recipients can be defined in the following mask. 

 

Illustration 6: E-mail recipient 

 The "Edit" button must be clicked to enable editing. It is checked whether the current mask is 
already being edited by another user. If so, no changes can be made. If not, the current mask 
will be authorized for the current user and locked for all other users. 

 A language can be assigned to each user. The alerts will be sent in the specified language. 

3.3.3 SMS recipient configuration 

 The SMS recipients are defined in the following mask: 

 

Illustration 7: SMS recipient 

 The "Edit" button must be clicked to enable editing. It is checked whether the current mask is 
already being edited by another user. If so, no changes can be made. If not, the current mask 
will be authorized for the current user and locked for all other users. 

 A language can be assigned to each user. The alerts will be sent in the specified language. 
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3.3.4 Database configuration 

 In this dialog, the correct parameters for the MySQL database must be entered: 

 

Illustration 8: Database configuration 

 

 
 
 

 

 

3.3.5 Client - Server communication configuration 

 In this dialogue, the correct parameters for the OMServer must be entered: 

 

 

3.4 Menu Info 

3.4.1 Help 

 Calls up the Help file (PDF File). 

3.4.2 Language 

 A dialog for the language selection will be opened: 

 

Illustration 9: Language selection 

 The combo box will display all the languages available. 

 Restart the application, if there are problems with the display after switching the language. 

3.4.3 About 

 The current version information will be displayed. 

 Name/IP address of the computer 
where the MySQL database is installed. 

 

 Port of the MySQL database (default: 
3306 - see Install Guide p. 11) 

 

 Name of the database (default: 
cs_omdatabase - see Install Guide p. 
13) 

 

 Database User: root 

 

 Password for the database access (see 
the Install Guide, p. 13 (default: 
CS_DB) 

 

 Name/IP address of the computer 
where the OMServer is installed. 

 

 Port of the OMServer (default: 47825 - 
see Manual Beko METPOINT connect 
OMServerGUI p. 13) 
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4 Overview 

 After the start the "Overview" screen will always be displayed. 

 If you are in another view, you can always switch back to the overview through the menu item 
"View -> Overview". 

 This screen can be freely configured by the user. 

 Background image: 
When using a background image, the devices can be positioned on the entire background 
image - otherwise on the entire screen. 

Menu item Toolbar Action 

Edit -> Wallpaper -> Add  Adding a background image 

Edit -> Wallpaper -> Delete  Deleting a background image 

Table 1: Background image 

 In the draft mode, devices can be added to the surface and positioned freely. The current 
measured values are displayed in the device window. An upcoming alarm or incorrect values 
are highlighted in red. 

Menu item Toolbar Action 

Edit -> Draft 
 

Draft mode on/off 

Edit -> Add device 
 

Dialog for adding a device is 
opened. Double-click on the 
desired device to add it. 

Table 2: Editing Overview 
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Illustration 10: Draft mode overview 

 The current overview will be saved automatically when you exit and loaded the next time the 
software is started. 

 As many overviews as desired can be saved. 
 

Menu item Toolbar Action 

File -> New  Creating a new overview. If 
the current view was not 
saved in a file, the data will be 
lost. 

File -> Open 
 

The dialog "Open file" with a 
filter for overview files ("*. 
cssh") will be opened. 

File -> Save  The currently selected file is 
saved. If no file is currently in 
use, the dialog "Save as ..." 
will automatically open. 

File -> Save as  The dialog "Save as ..." will 
open. When overview file are 
saved the file extension "*. 
cssh" is used. 

The frame is 
displayed in the 
draft mode. 

Deleting a device 

Alarm is pending. 

Draft mode active 
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Table 3: Overviews 

 Using the context menu, the following actions can be performed: 

o Graphical display of all measured values of the selected device within the selected 
time range. 

o Alarm configuration for the selected measured value (see 8 Alarm Configuration). 

5 Data 

 The menu item "View -> Data" switches to the data view. 

 A switching to the data view is also possible through the device context menu. 

 In the Diagram Explorer, all areas are listed to which the current user has access. The devices 
are structured as a tree diagram (area, device, measured value). 

 With the Chart Explorer data rows can be added or deleted by double-clicking on the 
appropriate measurement value. 

 Data rows can also be added/deleted through the context menu. 

 

Illustration 11: Diagram Explorer 
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 The line style can be changed via the context menu: 

 

Illustration 12: Line Style 

 In addition, the setting of the Y-axis is changed via the context menu. An Y-axis is added for 
each measured variable. 

 

Illustration 13: Y-axis scaling 

 The alarm configuration can also be started from the context menu (see 8 Alarm 
Configuration). 

 Depending on the selection of the TabControl in the Diagram Explorer, a different data field is 
loaded. The data is read optimized from the database (grouping of data - the maximum 
number of possible data points (screen width)). With the button "<<" or ">>" the same time 
span before or after is read from the database. 

 Using “Default” the range is set to the maximum range. 

 The Diagram Explorer can be docked to the left or right, or used as a floating window 
(Windows standard). 
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5.1 Diagram View 

 In the diagram view, the selected area is presented graphically: 

 

Illustration 14: Diagram View 

 Zoom 
Depending on the selection in the Diagram Explorer the X-axis (X-axis zoom) and/or Y-axis 
(Y-axis zoom) can be enlarged or reduced by using the scroll wheel. The selection can also be 
made via the context menu. 
 
By pressing the Shift key and selecting the desired range, the selected area is enlarged. 
 
By pressing the shift key and clicking an enlargement by one increment will be made. 
 
Pressing the ALT key and clicking will effect a reduction. 

Pressing the STRG key and +-key will lead to an enlargement by one increment. 
Pressing the STRG key and – key will lead to a reduction by one increment. 

 Measuring points: 
If the data does not have to be grouped for displaying, the raw data will be shown. The 
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measured value will be output in the tooltip. 

 

Illustration 15: Raw data diagram 

 Scrolling: 
Depending on the selection in the Diagram Explorer a scrolling is carried out along the x-axis 
(X-axis scrolling) and/or the Y-axis. The selection can also be made via the context menu. 
Hold down the left mouse button for scrolling. 

 Reset Y-scaling: 
Using the context menu "Zoom -> Reset Y-Axis scaling" all Y-axes are reset to auto scaling. 

 Data reloading: 
After zooming, you can use the context menu "Accept current time range" to load the 
maximum amount of data for the selected area. 

 Moving average: 
Using the context menu or the menu "Edit -> Moving average -> Display"  the moving average 
can be displayed/suppressed. 
The moving average can be configured via the menu "Edit -> Preferences -> Moving 
average". 

 

Illustration 16: Moving average 
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 Export: 
The current diagram can be printed or exported as various types of documents (PDF, HTML, 
MHT, Rich Text, Excel, CSV, Text, graphically) via the context menu "Export ..." or the menu 
"File -> Export ...". 

The chart diagram can be exported in the following formats: 
a) Hourly: One chart diagram per hour. 
b) Daily: One chart diagram per day. 
c) Weekly: One chart diagram per week. 

Selected timespan: print of current chart diagram. 

 Real-time data: 
The current data can be recorded by activating the tab "real-time data" in the Diagram 
Explorer. The maximum time frame to be displayed is specified in seconds. 

 Saving: 
The current settings (line style, time range ...) can he saved via the menu "File -> Save" and 
reloaded at a later point in time. Please note that the data is not stored in the file, but loaded 
from the database when the file is opened. When the diagram data is saved the file extension 
"*. csch" is used. 

5.2 Statistics 

 The loaded data will be analyzed statistically, and can be displayed through the tab 
"Statistics". 

 

Illustration 17: Statistical analysis 

 With the context menu or the menu "File -> Export ..." the statistical analysis can be output 
with or without graphics. 
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5.3 Tabular View 

 The loaded data will be output in a tabular form and can be displayed through the tab "Tabular 
view". 

 

Illustration 18: Tabular View 

 If an area within a table is marked, you can use the context menu "Accept current time frame" 
to reload the current data range. 

 The tabular view can be output through the context menu "Export ..." or via "File -> Export ...". 
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5.4 Raw Data 

 In the tab "raw data" the raw data of the database is output for the selected measurement 
values. If the number of data > width of the chart the grouped data will be output, otherwise 
the raw data. 

 

Illustration 19: Raw Data 

 The raw data can be output through the context menu "Export ..." or via "File -> Export ...". 

 With the context menu of the table heading the raw data can be output: 
 
a) sorted: 

 

Illustration 20: Chronological sorting ascending 
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b) filtered: 

 

Illustration 21: Filters - Value Name A1-2: A1b 

c) grouped: 

 

Illustration 22: Grouping Name Value 

. 
 

 

 

6 Alarm 

 Via the menu item "View -> Alarm", the alarm window is opened. 

 In the tab "Current Alarms" the current alarms are displayed. 

 Each alarm must be acknowledged. The acknowledgment is performed by clicking on the 
desired alarm and a subsequent acknowledging via the context menu. 

 Alarms that are no longer active and have been acknowledged will be moved to the alarm 
history. The alarm history can be opened from the tab "Alarm History". 

 In the alarm history the last 2000 entries are stored. 

 The server errors can be viewed from any OMClient via the tab "Server Messages". Here, the 
last 2000 entries are stored, which occurred on the server side (OMServer). 
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 Via the menu item "File -> Export ..." the current view can be exported. 

 

Illustration 23: Export 

 The preview can be printed or exported as various types of documents (PDF, HTML, MHT, 
Rich Text, Excel, CSV, Text, graphically) via the menu "Export ...". 

 With the context menu of the table heading the tabular view can be: 
a) sorted 

 

Illustration 24: "Duration" sorting, ascending 

b) filtered 

 

Illustration 25: Filters - Timeset from April 18, 2011 
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c) grouped 

 

Illustration 26: Grouping AreaName, DeviceName, ValueName 

Thus, enabling a detailed analysis of the alarms. 

7 Analysis 

 The menu item "View -> analysis" initiates the consumption analysis. 

 

Illustration 27: Consumption Analysis 

 The left pane lists all devices with consumption sensors, which are not considered in the 
consumption analysis. 
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 The right pane lists all devices with consumption sensors, which are considered in the 
consumption analysis. 

 With a double-click complete fields or only individual devices or channels can be moved from 
left to right or right to left. 
The selected area/unit/measuring channel can also be marked and moved with the "left arrow" 
or "right arrow" buttons. 

 The order of the areas, devices and measurement channels can also be defined. For this, use 
the "up arrow" and "down arrow" buttons. 

 Please note, that in order to execute a correct overall calculation devices that are included in a 
main or subtotal may not be considered. 

 The configuration can be saved through the menu "File -> Save" or via the appropriate icon. A 
saved configuration can be loaded at a later point in time can via "File -> Open". The file 
extension "*. csua" is used for the configuration files of the consumption analysis. The menu 
"File -> New" enables the creation of a new configuration. 

 Through the menu item "Extras->Config->Price" a price per unit as well as the rate 
selection/rate definition can be defined for every consumption channel. 

 

Illustration 1: Consumption Analysis configuration 

 Up to 5 shifts can be defined via the menu point „Extras->Config->shift work”. The shifts have 
to be carried out within one day and are not allowed to overlap, otherwise there will be an 
error message when confirming the input with the „OK“ button. 
The starting point of the first shift is allocated to the current day or the following day via the list 
field „Allocation of the shift start 1 to“. 
 
Example: 

Example 1 Example 2 

Start of shift:         22:00 h 
End of shift:          6:00 h 
Allocation:            next day 

Start of shift:        22:00 h 
End of shift:         6:00 h 
Allocation:           actual day 

If the first shift e. g. starts on Sunday at 
22:00 h and ends on Monday at 6:00 h the 
shift in this example will be allocated to 
Monday. 

If the first shift e. g. starts on Sunday at 
22:00 h and ends on Monday at 6:00 h the 
shift in this example will be allocated to 
Sunday. 
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Illustration 2: Configuration shift work 

 Please observe - that devices which are located in a main or sum branch may not be 
included if a correct sum-calculation is to be performed. 
Additionally, in order to perform a correct sum calculation only consumption variables 
with the same unit may be included. 

 Depending on the selection of the TabControl a weekly, monthly or annual report is create. 

 

Illustration 28: Consumption Analysis 

 The preview can be printed or exported as various types of documents (PDF, HTML, MHT, 
Rich Text, Excel, CSV, Text, graphically) via the menu "Export ...". 
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8 Alarm Configuration 

 The alarm configuration can be called up in the "Overview" view via the device context menu 
"Alarmconfiguration".

 

Illustration 29: Device context menu alarm configuration 
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 In addition, the alarm configuration can be executed from the context menu of the Diagram 
Explorer: 

 

Illustration 30: Diagram Explorer Alarm Configuration 

 2 limit values can be set for each measured value. Depending on the definition the following 
variants are possible: 
A) pre-alarm + main-alarm 
B) lower limit + upper limit  
 
For each alarm a switch-on delay and/or switch-off delay can be defined. An alarm text can be 
selected in the combo box "Alarm text". The definition of alarm texts is conducted either in the 
OMServerGUI or the OMClient (see 3.3.1 Alarm texts). 

 

Illustration 31: Alarm configuration, pre-alarm - main-alarm 
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Illustration 32: Alarm configuration, lower/upper limit 
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9 Support and Service 

If you have questions about our products, require technical support for the installation or use of our 
software or if you would like to give us a suggestion for improvements, BEKO TECHNOLOGIES 
GmbH offers you the following support options: 

Please contact us preferably via the following Internet site: 

http://www.beko-technologies.com 

 

 

 

Of course, you can also reach us by e-mail or phone. For this, please use the following e-mail address 
or the following phone number. 

beko@beko.de 

 

Please don't hesitate to send us a message. We will answer all inquiries within 24-48 hours. 

 

 

http://www.beko-technologies.com/
mailto:beko@beko.de

